Project

General

Profile

Bug #14027

tests: set --osd-scrub-load-threshold=2000

Added by Loïc Dachary about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

In a test environment, consistency is more important than
performances. Effectively disable the test that would postpone a scrub
depending on the load average. It is assumed that a machine with a load
average higher than 2000 won't be useable anyway.


Related issues

Related to Ceph - Bug #13986: TEST_scrub_snaps: timeout > 300 Resolved 12/05/2015

Associated revisions

Revision 99bcc7cf (diff)
Added by Loic Dachary about 7 years ago

tests: --osd-scrub-load-threshold=2000 for more consistency

In a test environment, consistency is more important than
performances. Effectively disable the test that would postpone a scrub
depending on the load average. It is assumed that a machine with a load
average higher than 2000 won't be useable anyway.

http://tracker.ceph.com/issues/14027 Refs: #14027

Signed-off-by: Loic Dachary <>

History

#2 Updated by Loïc Dachary about 7 years ago

  • Backport deleted (hammer,infernalis)

Although it would be worth porting to hammer and infernalis, the race conditions are rare enough that they effectively never show up on hammer and infernalis tests because they are not run as much.

#3 Updated by Loïc Dachary about 7 years ago

  • Related to Bug #13986: TEST_scrub_snaps: timeout > 300 added

#4 Updated by Loïc Dachary about 7 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF