Project

General

Profile

Bug #13647

plana81 yum broken

Added by Greg Farnum almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Test Node
Target version:
-
Start date:
10/30/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

{'plana81.front.sepia.ceph.com': {'item': 'ceph,ceph-common,ceph-debuginfo,ceph-release,libcephfs1,ceph-radosgw,python-ceph,python-rados,librbd1,librados2', 'rc': 1, 'failed': True, 'invocation': {'module_name': 'yum', 'module_args': ''}, 'changed': False, 'results': ['ceph is not installed', 'ceph-debuginfo is not installed', 'ceph-release is not installed', 'libcephfs1 is not installed', 'ceph-radosgw is not installed', 'python-ceph is not installed', 'python-rados is not installed', 'librbd1 is not installed', 'librados2 is not installed', 'Loaded plugins: fastestmirror, langpacks, priorities\n'], 'msg': 'Traceback (most recent call last):\n File "/usr/bin/yum", line 29, in <module>\n yummain.user_main(sys.argv[1:], exit_code=True)\n File "/usr/share/yum-cli/yummain.py", line 367, in user_main\n errcode = main(args)\n File "/usr/share/yum-cli/yummain.py", line 174, in main\n result, resultmsgs = base.doCommands()\n File "/usr/share/yum-cli/cli.py", line 571, in doCommands\n return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)\n File "/usr/share/yum-cli/yumcommands.py", line 866, in doCommand\n ret = base.erasePkgs(extcmds, pos=pos, basecmd=basecmd)\n File "/usr/share/yum-cli/cli.py", line 1196, in erasePkgs\n rms = self.remove(pattern=arg)\n File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 5376, in remove\n (e,m,u) = self.rpmdb.matchPackageNames([kwargs[\'pattern\']])\n File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 304, in matchPackageNames\n exactmatch.append(self.searchPkgTuple(pkgtup)[0])\nIndexError: list index out of range\n'}}

http://pulpito.ceph.com/ubuntu-2015-10-29_17:14:05-fs-greg-fs-testing---basic-multi/1130641 is one, there are several others in that run. I've no idea what these errors are about but runs on other machines are passing. I've marked plana81 down.

History

#1 Updated by Dan Mick almost 4 years ago

yum clean all didn't fix it. Looks like a straight up yum bug; don't know if there's any workaround.

#2 Updated by David Galloway almost 4 years ago

  • Related to Bug #13149: plana11: yum broken added

#3 Updated by David Galloway almost 4 years ago

  • Related to deleted (Bug #13149: plana11: yum broken)

#4 Updated by David Galloway over 3 years ago

  • Status changed from New to Rejected
  • Bulk Update **

Rejecting tickets related to leased Dell systems. We've moved out of Irvine and returned plana, burnupi, and vercoi to Dell.

Also available in: Atom PDF