Project

General

Profile

Bug #12778

epel repo issues

Added by Greg Farnum almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
08/25/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

2015-08-20T21:58:05.752 INFO:teuthology.orchestra.run.plana50.stderr: One of the configured repositories failed (Unknown),
2015-08-20T21:58:05.752 INFO:teuthology.orchestra.run.plana50.stderr: and yum doesn't have enough cached data to continue. At this point the only
2015-08-20T21:58:05.752 INFO:teuthology.orchestra.run.plana50.stderr: safe thing yum can do is fail. There are a few ways to work "fix" this:
2015-08-20T21:58:05.752 INFO:teuthology.orchestra.run.plana50.stderr:
2015-08-20T21:58:05.752 INFO:teuthology.orchestra.run.plana50.stderr:     1. Contact the upstream for the repository and get them to fix the problem.
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:     2. Reconfigure the baseurl/etc. for the repository, to point to a working
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:        upstream. This is most often useful if you are using a newer
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:        distribution release than is supported by the repository (and the
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:        packages for the previous distribution release still work).
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:     3. Disable the repository, so yum won't use it by default. Yum will then
2015-08-20T21:58:05.753 INFO:teuthology.orchestra.run.plana50.stderr:        just ignore the repository until you permanently enable it again or use
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:        --enablerepo for temporary usage:
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:            yum-config-manager --disable <repoid>
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:     4. Configure the failing repository to be skipped, if it is unavailable.
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:        Note that yum will try to contact the repo. when it runs most commands,
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:        so will have to try and fail each time (and thus. yum will be be much
2015-08-20T21:58:05.754 INFO:teuthology.orchestra.run.plana50.stderr:        slower). If it is a very temporary problem though, this is often a nice
2015-08-20T21:58:05.755 INFO:teuthology.orchestra.run.plana50.stderr:        compromise:
2015-08-20T21:58:05.755 INFO:teuthology.orchestra.run.plana50.stderr:
2015-08-20T21:58:05.755 INFO:teuthology.orchestra.run.plana50.stderr:            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true
2015-08-20T21:58:05.755 INFO:teuthology.orchestra.run.plana50.stderr:
2015-08-20T21:58:05.755 INFO:teuthology.orchestra.run.plana50.stderr:Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again

http://pulpito.ceph.com/teuthology-2015-08-17_23:08:05-kcephfs-master-testing-basic-multi/1020551/
http://pulpito.ceph.com/teuthology-2015-08-17_23:08:05-kcephfs-master-testing-basic-multi/1020548/
http://pulpito.ceph.com/teuthology-2015-08-17_23:08:05-kcephfs-master-testing-basic-multi/1020533/
http://pulpito.ceph.redhat.com/teuthology-2015-08-16_18:08:02-kcephfs-hammer-testing-basic-magna/175509/
http://pulpito.ceph.com/teuthology-2015-08-21_23:08:01-kcephfs-next-testing-basic-multi/1026122/

Dunno if this is a networking thing or something else, but it popped up in several places.


Related issues

Related to sepia - Bug #12739: vps runs on distros fail due to the epel timeout issue Resolved 08/20/2015

History

#1 Updated by Sage Weil almost 4 years ago

  • Priority changed from Normal to Urgent

#2 Updated by Andrew Schoen almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Andrew Schoen

I believe this is caused by a timeout to: http://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64

We initially stared to use mirrorlist because we had timeout issues with dl.fedoraproject.org, https://github.com/ceph/ceph-cm-ansible/pull/117

Changing to the mirrorlist helped us with those timeouts because yum will pick a new mirror if one is failing, but that won't help us if we timeout getting the mirror list from fedoraproject.org.

Perhaps we might want to host that metalink file ourselves?

#3 Updated by Andrew Schoen almost 4 years ago

A solution that ktdreyer suggested was to have ceph-cm-ansible create and manage a local mirrorlist on nodes that need it. This way we can have more fine grained control of the mirrors and it will eliminate a point of failure in downloading the file.

http://fedoranews.org/tchung/yum-mirrorlist/

#4 Updated by Andrew Schoen almost 4 years ago

We have a few directions we could go here:

1) increase the timeout and retires for yum when talking to mirrors
2) Use the mirrorlist link instead of metalink, the thought is that it might timeout less. http://mirrors.fedoraproject.org/mirrorlist?repo=epel-7&arch=x86_64
3) Have cm-ansible manage a local mirror list

The plan is to try option 1 first as it might be less evasive and won't have the maintenance burden of managing our own mirror list.

#5 Updated by Andrew Schoen almost 4 years ago

  • Status changed from In Progress to Need Review

Also available in: Atom PDF