Project

General

Profile

Bug #1233

ceph -v reports incorrect version

Added by Brian Chrisman over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I'm not sure what the .git_version file is supposed to be, as I see no reference in git docs to such a file.
From newdream's origin/master as of today,
./autogen.sh
./configure --without-tcmalloc # for my environment
cd src
make ceph_ver.h
grep CEPH_GIT_NICE_VER ceph_ver.h
----
#define CEPH_GIT_NICE_VER "0.24.2-2867-g19614bb"

History

#1 Updated by Brian Chrisman over 9 years ago

I am indeed betting that .git_version is a non-git file... though I think the name is pretty unfortunate... might be better as something like ceph_git_version or something to make it clear it's not supposed to be a standard file associated with 'git' directly.

#2 Updated by Brian Chrisman over 9 years ago

  • Status changed from New to Resolved

Not a bug... there's something hosed in the way I'm storing my git repo such that git describe is reporting an old version.

Also available in: Atom PDF