Project

General

Profile

Bug #11376

ceph-objectstore-tool should be in the "ceph" server package

Added by Ken Dreyer over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/13/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

From an IRC conversation with Greg Farnum: The ceph-objectstore-tool utility is a tool for interacting with the OSD objectstore. It's good for repairing clusters that have broken in a variety of ways. We expect users to need to run it sometimes (as well as support). It is like an fsck and repair tool for the OSD's store.

From this I conclude that we should move ceph-objectstore-tool to the main "ceph" package so that it is present on all OSDs. (and as far as ticket #10587 goes, ceph-objectstore-tool should eventually move to the new "ceph-osd" subpackage).

(It would also be great to have a ceph-objectstore-tool man page :)

Associated revisions

Revision 61cf5da0 (diff)
Added by Ken Dreyer over 4 years ago

packaging: mv ceph-objectstore-tool to main ceph pkg

This change ensures that the ceph-objectstore-tool utility is present on
all OSDs. This makes it easier for users to run this tool to do manual
debugging/recovery in some scenarios.

http://tracker.ceph.com/issues/11376 Refs: #11376

Signed-off-by: Ken Dreyer <>

Revision 46a4e8af (diff)
Added by Ken Dreyer over 4 years ago

packaging: mv ceph-objectstore-tool to main ceph pkg

This change ensures that the ceph-objectstore-tool utility is present on
all OSDs. This makes it easier for users to run this tool to do manual
debugging/recovery in some scenarios.

http://tracker.ceph.com/issues/11376 Refs: #11376

Signed-off-by: Ken Dreyer <>
(cherry picked from commit 61cf5da0b51e2d9578c7b4bca85184317e30f4ca)
Conflicts:
debian/control
because file layout changes from ceph-test and ceph << 0.94.1-46

History

#1 Updated by Ken Dreyer over 4 years ago

  • Status changed from New to Need Review
  • Backport changed from hammer,firefly to hammer

#3 Updated by Ken Dreyer over 4 years ago

  • Status changed from Need Review to Pending Backport
  • Regression set to No

#4 Updated by Ken Dreyer over 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF