Project

General

Profile

Bug #11285

RGW Swift API: showing stats in account listing does not work even when the "stats" parameter is provided

Added by Radoslaw Zarzynski almost 9 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

RGW via civetweb frontend:
$ curl -i http://localhost:8000/swift/v1/?format=json\&stats=true -X GET -H "X-Auth-Token: $token"

HTTP/1.1 200 OK
X-Timestamp: 1427809455.18849
X-Account-Container-Count: 0
X-Account-Object-Count: 0
X-Account-Bytes-Used: 0
X-Account-Bytes-Used-Actual: 0
Content-type: application/json; charset=utf-8
Content-Length: 189
Date: Tue, 31 Mar 2015 13:44:15 GMT

[{"name":"aaaa10","count":0,"bytes":0},{"name":"cont","count":8,"bytes":0},{"name":"cont10","count":0,"bytes":0},{"name":"cont12","count":0,"bytes":0},{"name":"cont15","count":2,"bytes":4}]

The issue occurs probably because send_response_begin() in RGWListBuckets::execute() is being called before collecting the statistics.


Related issues

Related to rgw - Feature #4759: rgw: option swift list container without container stats Resolved 04/19/2013

Associated revisions

Revision 3a5f9c38 (diff)
Added by Radoslaw Zarzynski almost 9 years ago

rgw: rectify broken statistics during Swift account listing.

Fixes: #11285
Backport: hammer
Signed-off-by: Radoslaw Zarzynski <>

History

#1 Updated by Radoslaw Zarzynski almost 9 years ago

  • Status changed from New to In Progress
  • Assignee set to Radoslaw Zarzynski

#2 Updated by Radoslaw Zarzynski almost 9 years ago

  • Status changed from In Progress to Fix Under Review

#3 Updated by Casey Bodley about 4 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF