Project

General

Profile

Bug #715

btrfs: extent-tree.c ( btrfs_free_block_group & release_global_block_rsv)

Added by Wido den Hollander over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
-
Start date:
01/17/2011
Due date:
% Done:

0%

Spent time:
Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

On 'noisy' I'm trying to run bonnie++ inside a Qemu-RBD virtual machine. After a while this gets stuck, the VM becomes unresponsive.

In the dmesg of the host (noisy) I get the following messages:

[164082.270828] ------------[ cut here ]------------
[164082.278813] WARNING: at /build/buildd/linux-lts-backport-natty-2.6.37/fs/btrfs/extent-tree.c:3872 release_global_block_rsv+0xe0/0xf0 [btrfs]()
[164082.287046] Hardware name: X7DVL
[164082.295295] Modules linked in: btrfs zlib_deflate libcrc32c ip6table_filter ip6_tables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ipt_REJECT xt_tcpudp iptable_filter ip_tables x_tables kvm_intel kvm radeon ttm bridge drm_kms_helper drm i5000_edac stp edac_core ioatdma i5k_amb serio_raw i2c_algo_bit ppdev shpchp ghes dca joydev parport_pc lp hed parport usbhid hid e1000e ahci libahci
[164082.322014] Pid: 11126, comm: umount Tainted: G      D W   2.6.37-12-server #26~lucid1-Ubuntu
[164082.330910] Call Trace:
[164082.339766]  [<ffffffff8106446f>] warn_slowpath_common+0x7f/0xc0
[164082.348748]  [<ffffffff810644ca>] warn_slowpath_null+0x1a/0x20
[164082.357656]  [<ffffffffa0345370>] release_global_block_rsv+0xe0/0xf0 [btrfs]
[164082.366602]  [<ffffffffa0345d06>] btrfs_free_block_groups+0x176/0x210 [btrfs]
[164082.375570]  [<ffffffff815c85ed>] ? wait_for_completion+0x1d/0x20
[164082.384614]  [<ffffffffa03568ab>] close_ctree+0x14b/0x290 [btrfs]
[164082.393678]  [<ffffffffa03383bd>] btrfs_put_super+0x1d/0x30 [btrfs]
[164082.402754]  [<ffffffff81164cd2>] generic_shutdown_super+0x72/0x100
[164082.411825]  [<ffffffff81164dc6>] kill_anon_super+0x16/0x60
[164082.420899]  [<ffffffff811657b5>] deactivate_locked_super+0x45/0x60
[164082.420903]  [<ffffffff811664ca>] deactivate_super+0x4a/0x70
[164082.420909]  [<ffffffff8117f117>] mntput_no_expire+0xd7/0x150
[164082.420913]  [<ffffffff8117f80c>] sys_umount+0x6c/0xd0
[164082.420919]  [<ffffffff8100c102>] system_call_fastpath+0x16/0x1b
[164082.420923] ---[ end trace 828fbab199ef16cb ]---
[164082.420927] ------------[ cut here ]------------
[164082.420939] WARNING: at /build/buildd/linux-lts-backport-natty-2.6.37/fs/btrfs/extent-tree.c:8239 btrfs_free_block_groups+0x1ab/0x210 [btrfs]()
[164082.420942] Hardware name: X7DVL
[164082.420944] Modules linked in: btrfs zlib_deflate libcrc32c ip6table_filter ip6_tables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ipt_REJECT xt_tcpudp iptable_filter ip_tables x_tables kvm_intel kvm radeon ttm bridge drm_kms_helper drm i5000_edac stp edac_core ioatdma i5k_amb serio_raw i2c_algo_bit ppdev shpchp ghes dca joydev parport_pc lp hed parport usbhid hid e1000e ahci libahci
[164082.420979] Pid: 11126, comm: umount Tainted: G      D W   2.6.37-12-server #26~lucid1-Ubuntu
[164082.420981] Call Trace:
[164082.420986]  [<ffffffff8106446f>] warn_slowpath_common+0x7f/0xc0
[164082.420990]  [<ffffffff810644ca>] warn_slowpath_null+0x1a/0x20
[164082.421001]  [<ffffffffa0345d3b>] btrfs_free_block_groups+0x1ab/0x210 [btrfs]
[164082.421005]  [<ffffffff815c85ed>] ? wait_for_completion+0x1d/0x20
[164082.421018]  [<ffffffffa03568ab>] close_ctree+0x14b/0x290 [btrfs]
[164082.421029]  [<ffffffffa03383bd>] btrfs_put_super+0x1d/0x30 [btrfs]
[164082.421033]  [<ffffffff81164cd2>] generic_shutdown_super+0x72/0x100
[164082.421036]  [<ffffffff81164dc6>] kill_anon_super+0x16/0x60
[164082.421040]  [<ffffffff811657b5>] deactivate_locked_super+0x45/0x60
[164082.421043]  [<ffffffff811664ca>] deactivate_super+0x4a/0x70
[164082.421047]  [<ffffffff8117f117>] mntput_no_expire+0xd7/0x150
[164082.421050]  [<ffffffff8117f80c>] sys_umount+0x6c/0xd0
[164082.421054]  [<ffffffff8100c102>] system_call_fastpath+0x16/0x1b
[164082.421057] ---[ end trace 828fbab199ef16cc ]---
[164082.421059] space_info has 1024493568 free, is not full
[164082.421063] space_info total=1082130432, used=49029120, pinned=0, reserved=153600, may_use=0, readonly=8454144
[164084.740019] ------------[ cut here ]------------

When I try to restart the OSD's one of them goes into Zombie state.

Now, since Sage has contributed some btrfs code I'm not sure if this is a btrfs bug or something in the OSD, that's why I'm creating this issue.

The OSD's do not crash, but one of them starts blocking due to this btrfs messages.

History

#1 Updated by Wido den Hollander over 8 years ago

  • Status changed from New to Closed

Closing this one, seems after all this was a real btrfs bug. Fixed in the latest tree.

Also available in: Atom PDF