Project

General

Profile

Bug #38769

rgw: nfs: librgw/NFS fails due to missing service setup

Added by Matt Benjamin 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
03/15/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
1 - critical
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Some new boilerplate from recent RGW refactoring is required in librgw. An unrelated illegal memory access from RGWPutObjProcessor has also been found.


Related issues

Duplicated by rgw - Bug #37767: librgw crash due to local variables deallocated Duplicate 12/27/2018
Copied to rgw - Backport #38774: nautilus: rgw: nfs: librgw/NFS fails due to missing service setup Resolved

History

#1 Updated by Matt Benjamin 3 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Casey Bodley 3 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #38774: nautilus: rgw: nfs: librgw/NFS fails due to missing service setup added

#4 Updated by Casey Bodley 3 months ago

  • Duplicated by Bug #37767: librgw crash due to local variables deallocated added

#5 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF