Project

General

Profile

Bug #38311

Ceph S3 enable Multipart

Added by kannan v 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
02/14/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Hi,
We have installed ceph. I am able to upload the files using S3 objectstore.
If I upload the file more than 80MB, then I am getting the below error

====
2019-02-07 19:17:28.317 7fe805aae700 0 rgw_init_ioctx ERROR: librados::Rados::pool_create returned (34) Numerical result out of range (this can be due to a pool or placement group misconfiguration, e.g. pg_num < pgp_num or mon_max_pg_per_osd exceeded) ====

If i upload the file with S3 option of disable multipart, then upload is successfully happening....
Is there a way to enable the multipart in Ceph S3?

Thanks,
Kannan V

History

#1 Updated by Greg Farnum 4 months ago

  • Project changed from Ceph to rgw
  • Category deleted (librados)

#2 Updated by Abhishek Lekshmanan 4 months ago

  • Tracker changed from Support to Bug
  • Status changed from New to Feedback
  • Regression set to No
  • Severity set to 3 - minor

This seems to be because rgw is trying to create a pool for tracking multipart metadata but most likely mon_max_pg_per_osd is exceeded. Try just ceph osd pool create testpool for eg. and that would fail as well with the default pg_num

#3 Updated by Abhishek Lekshmanan 4 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF