Project

General

Profile

Fix #36632

mgr/dashboard:update Python dependency

Added by Alfonso MH about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
dashboard/backend
Target version:
Start date:
10/30/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

We received a Github security warning regarding the following file:

https://github.com/ceph/ceph/blob/master/src/pybind/mgr/dashboard/requirements.txt

Known moderate severity security vulnerability detected in
requests <= 2.19.1 defined in requirements.txt.
requirements.txt update suggested: requests ~> 2.20.0.

We should update the dependency accordingly.

History

#1 Updated by Volker Theile about 2 months ago

  • Category set to dashboard/backend
  • Target version set to v14.0.0
  • Source set to Development

#2 Updated by Alfonso MH about 1 month ago

  • Status changed from New to Need Review
  • Assignee set to Alfonso MH

#4 Updated by Alfonso MH about 1 month ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF