Project

General

Profile

Bug #24909

RBD client IOPS pool stats are incorrect (2x higher; includes IO hints as an op)

Added by Jason Dillaman 6 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
Start date:
07/13/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

While running performance testing with Ceph metrics gathering statistics on the cluster, I noticed that while my RBD workload was generating ~7,000 writes/second to the cluster, Ceph metrics was showing my client is writing ~14,000 writes/second. Since these stats are just extracted from the PG stats, I looked into how those are calculated and it appears that "CEPH_OSD_OP_SETALLOCHINT" counts as a write op in terms of stat generation. Since RBD will send an alloc hint w/ each write op, it results in effectively double the write ops/second reported.


Related issues

Copied to RADOS - Backport #36556: luminous: RBD client IOPS pool stats are incorrect (2x higher; includes IO hints as an op) Resolved
Copied to RADOS - Backport #36557: mimic: RBD client IOPS pool stats are incorrect (2x higher; includes IO hints as an op) Resolved

History

#1 Updated by Jason Dillaman 6 months ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman 6 months ago

  • Status changed from In Progress to Need Review

#3 Updated by Greg Farnum 6 months ago

  • Subject changed from RBD client IOPS pool stats are incorrect (2x higher) to RBD client IOPS pool stats are incorrect (2x higher; includes IO hints as an op)

#4 Updated by Yuri Weinstein 6 months ago

Jason Dillaman wrote:

https://github.com/ceph/ceph/pull/23029

merged

#5 Updated by Jason Dillaman 3 months ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #36556: luminous: RBD client IOPS pool stats are incorrect (2x higher; includes IO hints as an op) added

#7 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #36557: mimic: RBD client IOPS pool stats are incorrect (2x higher; includes IO hints as an op) added

#8 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF