Project

General

Profile

Bug #24872

qa: client socket inaccessible without sudo

Added by Patrick Donnelly 5 months ago. Updated 7 days ago.

Status:
Pending Backport
Priority:
Urgent
Category:
Testing
Target version:
Start date:
07/11/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa
Pull request ID:

Description

https://github.com/ceph/ceph/blob/5688476513a78cf9ab2cf3b1f65e6244f05ea73d/qa/tasks/cephfs/fuse_mount.py#L377

glob silently fails because /var/run/ceph is not accessible by the ubuntu user. This appears to be a new issue caused by a change in the directory permissions post-mimic.


Related issues

Copied to fs - Backport #24904: mimic: qa: client socket inaccessible without sudo Resolved
Copied to fs - Backport #37623: luminous: qa: client socket inaccessible without sudo In Progress

History

#1 Updated by Patrick Donnelly 5 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Patrick Donnelly 5 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #24904: mimic: qa: client socket inaccessible without sudo added

#4 Updated by Nathan Cutler 5 months ago

  • Status changed from Pending Backport to Resolved

#5 Updated by Nathan Cutler 7 days ago

  • Backport changed from mimic to mimic, luminous

#6 Updated by Nathan Cutler 7 days ago

  • Status changed from Resolved to Pending Backport

#7 Updated by Nathan Cutler 7 days ago

  • Copied to Backport #37623: luminous: qa: client socket inaccessible without sudo added

Also available in: Atom PDF