Project

General

Profile

Bug #23644

when no OSDs are found to activate an AttributeError is raised

Added by Alfredo Deza 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
04/10/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

This is similar to what happens in activate_filestore but we didn't have it here and I noticed it with this failure:

File "/usr/lib/python2.7/dist-packages/ceph_volume/devices/lvm/activate.py", line 115, in activate_bluestore
  is_encrypted = osd_lv.tags.get('ceph.encrypted', '0') == '1'
AttributeError: 'NoneType' object has no attribute 'tags'

This happened because we were missing the --filestore flag, so it defaulted to bluestore, where no OSDs could be found. This change should be backported

This commit was merged in master, and this ticket should only target Luminous:

https://github.com/ceph/ceph/pull/21130/commits/b1920d6e731f194c4829810d849dba6b087ce3a4

History

#2 Updated by Alfredo Deza 11 months ago

  • Status changed from In Progress to Resolved

merged commit 459cd9f into luminous

Also available in: Atom PDF