Project

General

Profile

Bug #23253

Assertion is raised when fetching file event in Ceph 12.2.1

Added by yupeng chen 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
03/07/2018
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
fs
Pull request ID:

Description

Our MDS run into the PurgeQueue issue mentioned in http://tracker.ceph.com/issues/19593.
Since then it had been trying respawning continually but unsuccessfully. And during one respawning, it crashed with the following backtrace:

2018-03-06 14:48:14.121164 7f34ccbff700 -1 /home/repo/rpmbuild/BUILD/ceph-12.2.1.1/src/msg/async/Event.h: In function 'EventCenter::FileEvent* EventCenter::_get_file_event(int)' thread 7f34ccbff700 time 2018-03-06 14:48:14.118004
/home/repo/rpmbuild/BUILD/ceph-12.2.1.1/src/msg/async/Event.h: 180: FAILED assert(fd < nevent)

ceph version 12.2.1.1 (28566d962f00c04cb94ee600bf896f7685b0497f) luminous (stable)
1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x110) [0x7f34d80b8940]
2: (()+0x29763c) [0x7f34d7d7b63c]
3: (EventCenter::create_file_event(int, int, EventCallback*)+0x365) [0x7f34d814e705]
4: (EventCenter::set_owner()+0x5d9) [0x7f34d8151069]
5: (()+0x66e0c2) [0x7f34d81520c2]
6: (()+0xb52b0) [0x7f34d55932b0]
7: (()+0x7e25) [0x7f34d5c18e25]
8: (clone()+0x6d) [0x7f34d4cfb34d]

Apparently, it's caused by an index overflow.


Related issues

Copied to Ceph - Backport #23306: luminous: Assertion is raised when fetching file event in Ceph 12.2.1 Resolved

History

#2 Updated by Kefu Chai 11 months ago

  • Status changed from New to Need Review
  • Assignee set to yupeng chen
  • Priority changed from Normal to High
  • Target version deleted (v12.2.2)
  • Backport set to luminous

#3 Updated by Kefu Chai 11 months ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #23306: luminous: Assertion is raised when fetching file event in Ceph 12.2.1 added

#5 Updated by Greg Farnum 10 months ago

  • Project changed from Ceph to fs
  • Category deleted (msgr)

#6 Updated by Nathan Cutler 10 months ago

  • Project changed from fs to Ceph

moving to Ceph because it's a bug in msgr

#7 Updated by Nathan Cutler 10 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF