Project

General

Profile

Bug #22996

Snapset inconsistency is no longer detected

Added by David Zafman 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
02/13/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

The fix for #20243 required additional handling of snapset inconsistency. The Object info and snapset aren't part of at the user attr inconsistency checking.


Related issues

Copied to RADOS - Backport #23054: luminous: Snapset inconsistency is no longer detected Resolved

History

#1 Updated by David Zafman 11 months ago

  • Description updated (diff)
  • Status changed from New to Verified
  • Assignee set to David Zafman
  • Priority changed from Normal to Urgent

#2 Updated by Greg Farnum 11 months ago

We also need this fix to include tests that happen in the QA suite to prevent a future regression! :)
(Presumably that won’t be difficult since the objectstore tool already supports corrupting these?)

#3 Updated by David Zafman 11 months ago

  • Status changed from Verified to Need Review

#4 Updated by David Zafman 11 months ago

  • Backport set to jewel, luminous

#5 Updated by David Zafman 11 months ago

  • Backport changed from jewel, luminous to luminous

#6 Updated by Kefu Chai 11 months ago

  • Status changed from Need Review to Pending Backport

#7 Updated by David Zafman 11 months ago

  • Copied to Backport #23054: luminous: Snapset inconsistency is no longer detected added

#8 Updated by David Zafman 11 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF