Project

General

Profile

Bug #22791

[librbd] force removing snapshots cannot remove children

Added by Jason Dillaman over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
01/24/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Using "rbd snap remove --force <snap-spec>" will flatten all child images. However, if the deep-flatten feature isn't enabled on the child images, it currently removes the image from the "rbd_children" object which will result in corrupt snapshots of the child images (since they weren't deeply flattened).


Related issues

Copied to rbd - Backport #22806: luminous: [librbd] force removing snapshots cannot remove children Resolved

History

#1 Updated by Jason Dillaman over 1 year ago

  • Status changed from In Progress to Need Review

#2 Updated by Mykola Golub over 1 year ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #22806: luminous: [librbd] force removing snapshots cannot remove children added

#4 Updated by Jason Dillaman over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF