Project

General

Profile

Bug #22717

mgr: prometheus: impossible to join labels from metadata metrics.

Added by Konstantin Shalygin over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
prometheus module
Target version:
Start date:
01/17/2018
Due date:
% Done:

0%

Source:
Community (user)
Tags:
prometheus mgr
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:

Description

By default we have pool metrics like this:

ceph_pool_objects{pool_id="1"} 1075534
ceph_pool_metadata{name="name_of_pool_1",pool_id="1"} 0

When I was try to join 'name' label from metadata series (to use label with Grafana) like this:

ceph_pool_objects * on (pool_id) group_left(name) ceph_pool_metadata

Result returned without metric, only labels:

{name="name_of_pool_1",pool_id="1"}

This is because metadata metric always have value '0'.
This behavior will be fixed if set value to '1'.

Selection_002.png View (76.4 KB) Konstantin Shalygin, 01/17/2018 06:21 AM

History

#2 Updated by John Spray over 1 year ago

  • Status changed from New to Need Review
  • Backport set to luminous

#3 Updated by John Spray over 1 year ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF