Project

General

Profile

Bug #22475

qa: full flag not set on osdmap for tasks.cephfs.test_full.TestClusterFull.test_full_different_file

Added by Patrick Donnelly about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
-
Start date:
12/19/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
Pull request ID:

Description

2017-12-19T03:44:06.475 INFO:teuthology.orchestra.run.smithi113.stdout:
2017-12-19T03:44:06.476 INFO:teuthology.orchestra.run.smithi113.stdout:{
2017-12-19T03:44:06.476 INFO:teuthology.orchestra.run.smithi113.stdout:    "epoch": 41,
2017-12-19T03:44:06.476 INFO:teuthology.orchestra.run.smithi113.stdout:    "fsid": "9694d42f-fac4-469f-9d0e-6198e773d18e",
2017-12-19T03:44:06.476 INFO:teuthology.orchestra.run.smithi113.stdout:    "created": "2017-12-19 03:41:22.700394",
2017-12-19T03:44:06.476 INFO:teuthology.orchestra.run.smithi113.stdout:    "modified": "2017-12-19 03:44:05.434137",
2017-12-19T03:44:06.476 INFO:teuthology.orchestra.run.smithi113.stdout:    "flags": "sortbitwise,recovery_deletes,purged_snapdirs",

From: http://pulpito.ceph.com/pdonnell-2017-12-19_03:02:31-fs-mimic-dev1-testing-basic-smithi/1977782/

which is checked here:

https://github.com/ceph/ceph/blob/6e905de9bff50315dfae2a57bb2b1da837160ca0/qa/tasks/cephfs/filesystem.py#L360-L362

since: b4ca5ae462c6f12ca48b787529938862646282cd


Related issues

Related to fs - Bug #22483: mds: check for CEPH_OSDMAP_FULL is now wrong; cluster full flag is obsolete Resolved 12/19/2017
Copied to fs - Backport #22580: luminous: qa: full flag not set on osdmap for tasks.cephfs.test_full.TestClusterFull.test_full_different_file Resolved

History

#2 Updated by Patrick Donnelly about 1 year ago

  • Status changed from New to Need Review

#3 Updated by Nathan Cutler about 1 year ago

  • Backport set to luminous

Flagging for luminous backport because b4ca5ae (which presumably introduced the test failure this is fixing (?)) was cherry-picked to luminous.

#4 Updated by Patrick Donnelly about 1 year ago

  • Related to Bug #22483: mds: check for CEPH_OSDMAP_FULL is now wrong; cluster full flag is obsolete added

#5 Updated by Patrick Donnelly about 1 year ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #22580: luminous: qa: full flag not set on osdmap for tasks.cephfs.test_full.TestClusterFull.test_full_different_file added

#7 Updated by Nathan Cutler 12 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF