Project

General

Profile

Bug #22285

_read_bdev_label unable to decode label at offset

Added by Alwin Antreich over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/30/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

While maybe not directly triggered by ceph-volume, the following error is displayed on osd creation. OSD is still created and starts.

 stderr: 2017-11-30 15:30:48.794603 7f3555cf6e00 -1 bluestore(/var/lib/ceph/osd/ceph-17//block) _read_bdev_label unable to decode label at offset 102: buffer::malformed_input: void bluestore_bdev_label_t::decode(ceph::buffer::list::iterator&) decode past end of struct encoding

Complete output:

root@sumi2:~# ceph-volume lvm create --bluestore --data /dev/sdg
Running command: sudo vgcreate --force --yes ceph-8676e29c-801c-49d6-9809-1a3486b93a05 /dev/sdg
 stdout: Volume group "ceph-8676e29c-801c-49d6-9809-1a3486b93a05" successfully created
Running command: sudo lvcreate --yes -l 100%FREE -n osd-block-bd3a04ed-b14e-4a16-b3d9-8b742be019a4 ceph-8676e29c-801c-49d6-9809-1a3486b93a05
 stdout: Logical volume "osd-block-bd3a04ed-b14e-4a16-b3d9-8b742be019a4" created.
Running command: sudo mount -t tmpfs tmpfs /var/lib/ceph/osd/ceph-17
Running command: chown -R ceph:ceph /dev/dm-7
Running command: sudo ln -s /dev/ceph-8676e29c-801c-49d6-9809-1a3486b93a05/osd-block-bd3a04ed-b14e-4a16-b3d9-8b742be019a4 /var/lib/ceph/osd/ceph-17/block
Running command: sudo ceph --cluster ceph --name client.bootstrap-osd --keyring /var/lib/ceph/bootstrap-osd/ceph.keyring mon getmap -o /var/lib/ceph/osd/ceph-17/activate.monmap
 stderr: got monmap epoch 3
Running command: ceph-authtool /var/lib/ceph/osd/ceph-17/keyring --create-keyring --name osd.17 --add-key AQAXFiBaTGFoJxAAtoksLzVGxzJ+j3QuLSnFCQ==
 stdout: creating /var/lib/ceph/osd/ceph-17/keyring
 stdout: added entity osd.17 auth auth(auid = 18446744073709551615 key=AQAXFiBaTGFoJxAAtoksLzVGxzJ+j3QuLSnFCQ== with 0 caps)
Running command: chown -R ceph:ceph /var/lib/ceph/osd/ceph-17/keyring
Running command: chown -R ceph:ceph /var/lib/ceph/osd/ceph-17/
Running command: sudo ceph-osd --cluster ceph --osd-objectstore bluestore --mkfs -i 17 --monmap /var/lib/ceph/osd/ceph-17/activate.monmap --key **************************************** --osd-data /var/lib/ceph/osd/ceph-17/ --osd-uuid bd3a04ed-b14e-4a16-b3d9-8b742be019a4 --setuser ceph --setgroup ceph
 stderr: 2017-11-30 15:30:48.794603 7f3555cf6e00 -1 bluestore(/var/lib/ceph/osd/ceph-17//block) _read_bdev_label unable to decode label at offset 102: buffer::malformed_input: void bluestore_bdev_label_t::decode(ceph::buffer::list::iterator&) decode past end of struct encoding
 stderr: 2017-11-30 15:30:48.794746 7f3555cf6e00 -1 bluestore(/var/lib/ceph/osd/ceph-17//block) _read_bdev_label unable to decode label at offset 102: buffer::malformed_input: void bluestore_bdev_label_t::decode(ceph::buffer::list::iterator&) decode past end of struct encoding
2017-11-30 15:30:48.794872 7f3555cf6e00 -1 bluestore(/var/lib/ceph/osd/ceph-17//block) _read_bdev_label unable to decode label at offset 102: buffer::malformed_input: void bluestore_bdev_label_t::decode(ceph::buffer::list::iterator&) decode past end of struct encoding
2017-11-30 15:30:48.794947 7f3555cf6e00 -1 bluestore(/var/lib/ceph/osd/ceph-17/) _read_fsid unparsable uuid
 stderr: 2017-11-30 15:30:50.116608 7f3555cf6e00 -1 key AQAXFiBaTGFoJxAAtoksLzVGxzJ+j3QuLSnFCQ==
 stderr: 2017-11-30 15:30:50.647578 7f3555cf6e00 -1 created object store /var/lib/ceph/osd/ceph-17/ for osd.17 fsid 5a03e18d-d99d-4686-878c-f48dcdab3270
Running command: sudo ceph-bluestore-tool --cluster=ceph prime-osd-dir --dev /dev/ceph-8676e29c-801c-49d6-9809-1a3486b93a05/osd-block-bd3a04ed-b14e-4a16-b3d9-8b742be019a4 --path /var/lib/ceph/osd/ceph-17
Running command: sudo ln -snf /dev/ceph-8676e29c-801c-49d6-9809-1a3486b93a05/osd-block-bd3a04ed-b14e-4a16-b3d9-8b742be019a4 /var/lib/ceph/osd/ceph-17/block
Running command: chown -R ceph:ceph /dev/dm-7
Running command: chown -R ceph:ceph /var/lib/ceph/osd/ceph-17
Running command: sudo systemctl enable ceph-volume@lvm-17-bd3a04ed-b14e-4a16-b3d9-8b742be019a4
 stderr: Created symlink /etc/systemd/system/multi-user.target.wants/ceph-volume@lvm-17-bd3a04ed-b14e-4a16-b3d9-8b742be019a4.service → /lib/systemd/system/ceph-volume@.service.
Running command: sudo systemctl start ceph-osd@17


Related issues

Copied to bluestore - Backport #22892: luminous: _read_bdev_label unable to decode label at offset Resolved

History

#1 Updated by Alfredo Deza over 1 year ago

  • Project changed from Ceph to RADOS
  • Subject changed from ceph-volume - _read_bdev_label unable to decode label at offset to _read_bdev_label unable to decode label at offset

This is expected behavior coming from bluestore when it is first created, because (iirc) it hasn't been initialized yet, so the read fails.

In ceph-volume, right after `ceph-osd` is being called, it proceeds to populate the directory, so all the complaining up until that point no longer matters:

Running command: sudo ceph-bluestore-tool --cluster=ceph prime-osd-dir --dev /dev/ceph-8676e29c-801c-49d6-9809-1a3486b93a05/osd-block-bd3a04ed-b14e-4a16-b3d9-8b742be019a4 --path /var/lib/ceph/osd/ceph-17

Not sure if bluestore should try to log something differently there, or if it can even tell the difference between what "malformed input" is vs. not initialized

Will move this to rados/bluestore so someone else can decide what to do here (if anything)

#2 Updated by Alfredo Deza over 1 year ago

  • Project changed from RADOS to bluestore
  • Status changed from New to Verified

#3 Updated by Sage Weil over 1 year ago

  • Status changed from Verified to Pending Backport
  • Backport set to luminous

#5 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #22892: luminous: _read_bdev_label unable to decode label at offset added

#6 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF