Project

General

Profile

Bug #22095

ceph status shows wrong number of objects

Added by Jan Fajerski over 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/09/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

With a large number of objects the output of ceph status is wrong. Consider the folowing:
ceph -s:
objects: 6835M objects, 163 TB

ceph df details:
test_pool 18 N/A N/A 161T 8.29 595T 7150896726 6819M 1 10059M 484T

Seems like the status command uses 1024 as the multiplier for K and M suffixes


Related issues

Copied to RADOS - Backport #23772: luminous: ceph status shows wrong number of objects Resolved

History

#1 Updated by Jan Fajerski over 1 year ago

  • Subject changed from ceph status show wrong number of obejects to ceph status shows wrong number of objects

#3 Updated by Nathan Cutler over 1 year ago

  • Status changed from New to Need Review
  • Assignee set to Jan Fajerski
  • Backport set to luminous

#4 Updated by Kefu Chai 11 months ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #23772: luminous: ceph status shows wrong number of objects added

#6 Updated by Nathan Cutler 6 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF