Project

General

Profile

Bug #21518

mgr[zabbix] float division by zero

Added by Ilja Slepnev about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
ceph-mgr
Target version:
-
Start date:
09/22/2017
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

Enabled Zabbix module, configured as described on http://docs.ceph.com/docs/master/mgr/zabbix/, but no data is received.
float division by zero is logged in ceph-mgr.log


Related issues

Duplicated by mgr - Bug #23135: mgr zabbix module don't work with osds lost Duplicate 02/26/2018
Copied to mgr - Backport #21648: luminous: mgr[zabbix] float division by zero Resolved

History

#1 Updated by Ilja Slepnev about 1 year ago

After upgrading all OSDs to bluestore, the issue resolved.

One of OSD had filestore format while others had bluestore. This may be related to the issue.
No more "division by zero" message and data is actually sent by zabbix_sender, verified by using tcpdump.

#2 Updated by John Spray about 1 year ago

  • Status changed from New to Need Review
  • Backport set to luminous

By inspection, I'm assuming this was happening in the avg() function due to lack of data (why there was no data is a separate mystery...)

https://github.com/ceph/ceph/pull/17931

#3 Updated by Sage Weil about 1 year ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #21648: luminous: mgr[zabbix] float division by zero added

#5 Updated by Kefu Chai 11 months ago

  • Status changed from Pending Backport to Resolved

#6 Updated by John Spray 8 months ago

  • Duplicated by Bug #23135: mgr zabbix module don't work with osds lost added

Also available in: Atom PDF