Project

General

Profile

Bug #21029

TestMirroringWatcher.ModeUpdated: periodic failure due to injected message failures

Added by Jason Dillaman almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
08/17/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

2017-08-17T19:03:01.491 INFO:tasks.workunit.client.0.smithi063.stdout:[----------] 2 tests from TestMirroringWatcher
2017-08-17T19:03:04.358 INFO:tasks.workunit.client.0.smithi063.stdout:using image data pool: datapool
2017-08-17T19:03:04.361 INFO:tasks.workunit.client.0.smithi063.stdout:[ RUN      ] TestMirroringWatcher.ModeUpdated
2017-08-17T19:03:07.149 INFO:tasks.workunit.client.0.smithi063.stdout:/build/ceph-12.1.2-835-ga61bd47/src/test/librbd/test_MirroringWatcher.cc:75: Failure
2017-08-17T19:03:07.153 INFO:tasks.workunit.client.0.smithi063.stdout:Mock function called more times than expected - returning directly.
2017-08-17T19:03:07.155 INFO:tasks.workunit.client.0.smithi063.stdout:    Function call: handle_mode_updated(disabled)
2017-08-17T19:03:07.158 INFO:tasks.workunit.client.0.smithi063.stdout:         Expected: to be called once
2017-08-17T19:03:07.160 INFO:tasks.workunit.client.0.smithi063.stdout:           Actual: called twice - over-saturated and active
2017-08-17T19:03:07.162 INFO:tasks.workunit.client.0.smithi063.stdout:[  FAILED  ] TestMirroringWatcher.ModeUpdated (2799 ms)
2017-08-17T19:03:07.165 INFO:tasks.workunit.client.0.smithi063.stdout:[ RUN      ] TestMirroringWatcher.ImageStatusUpdated
2017-08-17T19:03:07.209 INFO:tasks.workunit.client.0.smithi063.stdout:[       OK ] TestMirroringWatcher.ImageStatusUpdated (51 ms)
2017-08-17T19:03:07.797 INFO:tasks.workunit.client.0.smithi063.stdout:[----------] 2 tests from TestMirroringWatcher (2850 ms total)

Related issues

Copied to rbd - Backport #21045: luminous: TestMirroringWatcher.ModeUpdated: periodic failure due to injected message failures Resolved

History

#1 Updated by Jason Dillaman almost 2 years ago

  • Status changed from In Progress to Need Review

#2 Updated by Venky Shankar almost 2 years ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #21045: luminous: TestMirroringWatcher.ModeUpdated: periodic failure due to injected message failures added

#4 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF