Project

General

Profile

Bug #20865

12.1.1: BlueStore OSD reports osd_objectstore: filestore

Added by Florian Haas 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
-
Start date:
08/01/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Just deployed a BlueStore OSD on the Luminous RC. Definitely looks like it's running BlueStore:

$ ls -la /var/lib/ceph/osd/ceph-0
total 56
drwxr-xr-x 2 ceph ceph  234 Jul 31 22:16 .
drwxr-xr-x 3 ceph ceph 4096 Jul 31 16:15 ..
-rw-r--r-- 1 root root  390 Jul 31 22:16 activate.monmap
-rw-r--r-- 1 ceph ceph    3 Jul 31 22:16 active
lrwxrwxrwx 1 ceph ceph   58 Jul 31 22:16 block -> /dev/disk/by-partuuid/293f9526-6707-41ee-859c-8aea4972cbcf
-rw-r--r-- 1 ceph ceph   37 Jul 31 22:16 block_uuid
-rw-r--r-- 1 ceph ceph    2 Jul 31 22:16 bluefs
-rw-r--r-- 1 ceph ceph   37 Jul 31 22:16 ceph_fsid
-rw-r--r-- 1 ceph ceph   37 Jul 31 22:16 fsid
-rw------- 1 ceph ceph   56 Jul 31 22:16 keyring
-rw-r--r-- 1 ceph ceph    8 Jul 31 22:16 kv_backend
-rw-r--r-- 1 ceph ceph   21 Jul 31 22:16 magic
-rw-r--r-- 1 ceph ceph    4 Jul 31 22:16 mkfs_done
-rw-r--r-- 1 ceph ceph    6 Jul 31 22:16 ready
-rw-r--r-- 1 ceph ceph    0 Jul 31 22:17 systemd
-rw-r--r-- 1 ceph ceph   10 Jul 31 22:16 type
-rw-r--r-- 1 ceph ceph    2 Jul 31 22:16 whoami

But doesn't say it's running BlueStore:

$ sudo ceph daemon osd.0 config get osd_objectstore
{
    "osd_objectstore": "filestore" 
}
<pre>

This breaks what would be a rather nice way to detect which store an OSD is currently running.

History

#1 Updated by Chang Liu 3 months ago

  • Status changed from New to Verified
  • Assignee set to Chang Liu

#2 Updated by Chang Liu 3 months ago

  • Status changed from Verified to Need Review
  • Assignee deleted (Chang Liu)

#3 Updated by Nathan Cutler 3 months ago

  • Subject changed from 12.2.1: BlueStore OSD reports osd_objectstore: filestore to 12.1.1: BlueStore OSD reports osd_objectstore: filestore

12.2.1 is not out yet; the reporter probably intended 12.1.1

#4 Updated by Kefu Chai 3 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF