Project

General

Profile

Bug #20803

ceph tell osd.N config set osd_max_backfill does not work

Added by Sage Weil 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
Start date:
07/27/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No
Component(RADOS):

Description

root@eutow:~# ceph daemon osd.33 dump_reservations
...
        "max_allowed": 1,
...
root@eutow:~# ceph tell osd.33 injectargs '--osd-max-backfills 10'
osd_max_backfills = '10' rocksdb_separate_wal_dir = 'false' (not observed, change may require restart) 
root@eutow:~# ceph daemon osd.33 dump_reservations
{
    "local_reservations": {
        "max_allowed": 10,
...
root@eutow:~# ceph tell osd.33 config set osd_max_backfills 9
Set osd_max_backfills to 9
root@eutow:~# ceph daemon osd.33 dump_reservations
{
    "local_reservations": {
        "max_allowed": 10,
...

not sure if this is specific to this particular setting, or a general problem with 'ceph tell <daemon> config set <thing> <val>'.

History

#1 Updated by Sage Weil 3 months ago

  • Description updated (diff)

#2 Updated by John Spray 3 months ago

  • Status changed from Verified to In Progress
  • Assignee set to John Spray

OK, looks like this is setting the option (visible in "config show") but not calling the handlers properly (not reflected in the dump_reservations).

#3 Updated by John Spray 3 months ago

  • Status changed from In Progress to Need Review

#4 Updated by Sage Weil 3 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF