Project

General

Profile

Bug #20751

osd_state not updated properly during osd-reuse-id.sh

Added by Sage Weil 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
07/22/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No
Component(RADOS):

Description

when running osd-reuse-id.sh via teuthology i reliably fail an assert about all osds support the stateful mon subscriptions. that happens because when 'osd new' runs the state somehow ends up with teh UP bit set when it shouldn't be.

/a/sage-2017-07-23_01:26:46-rados:standalone-wip-standalone-distro-basic-smithi/1432683

for latest instance (altho there are no logs there)


Related issues

Duplicated by Ceph - Bug #20679: ceph-disk prepare --osd-id 123 silently uses another id if 123 is not destroyed Duplicate 07/18/2017
Duplicated by RADOS - Bug #20933: All mon nodes down when i use ceph-disk prepare a new osd. Closed 08/07/2017

History

#1 Updated by Sage Weil 3 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Sage Weil 3 months ago

  • Status changed from Need Review to Resolved

#3 Updated by Sage Weil 3 months ago

  • Status changed from Resolved to In Progress

Hmm, we should also ensure that UP is cleared when doing the destroy, since existing clusters may have osds that !EXISTS but have UP.

#4 Updated by Sage Weil 3 months ago

  • Priority changed from Immediate to Urgent

#5 Updated by Sage Weil 3 months ago

  • Duplicated by Bug #20679: ceph-disk prepare --osd-id 123 silently uses another id if 123 is not destroyed added

#6 Updated by Sage Weil 3 months ago

  • Status changed from In Progress to Need Review

follow-up defensive change: https://github.com/ceph/ceph/pull/16534

#7 Updated by Sage Weil 3 months ago

  • Status changed from Need Review to Resolved

#8 Updated by Greg Farnum 2 months ago

  • Duplicated by Bug #20933: All mon nodes down when i use ceph-disk prepare a new osd. added

Also available in: Atom PDF