Project

General

Profile

Bug #20448

rgw: crash with rgw_run_sync_thread=false

Added by Aleksei Gutikov over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
06/28/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:

Description

Segfault at:
main()
rest_filter()
sync_module is empty because it was not created in RGWRados::init_complete()


Related issues

Copied to rgw - Backport #23318: luminous: rgw: crash with rgw_run_sync_thread=false Resolved

History

#1 Updated by Orit Wasserman over 1 year ago

  • Assignee set to Casey Bodley

#2 Updated by Orit Wasserman about 1 year ago

  • Subject changed from luminous: rgw: crash with rgw_run_sync_thread=false to rgw: crash with rgw_run_sync_thread=false
  • Backport set to luminous

#4 Updated by Orit Wasserman about 1 year ago

  • Assignee changed from Casey Bodley to Orit Wasserman

#5 Updated by Yehuda Sadeh about 1 year ago

  • Status changed from New to Testing
  • Priority changed from Normal to High

#6 Updated by Yuri Weinstein about 1 year ago

Orit Wasserman wrote:

https://github.com/ceph/ceph/pull/20769

merged

#7 Updated by Casey Bodley about 1 year ago

  • Status changed from Testing to Pending Backport

#8 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #23318: luminous: rgw: crash with rgw_run_sync_thread=false added

#9 Updated by Nathan Cutler about 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF