Project

General

Profile

Bug #20185

[cli] ensure positional arguments exist before casting

Added by Jason Dillaman 6 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
06/05/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

For example: "rbd feature enable --image xyz" will crash since the feature name positional was not specified.


Related issues

Copied to rbd - Backport #20264: kraken: [cli] ensure positional arguments exist before casting Resolved
Copied to rbd - Backport #20265: jewel: [cli] ensure positional arguments exist before casting Resolved

History

#1 Updated by Jason Dillaman 6 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Mykola Golub 5 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #20264: kraken: [cli] ensure positional arguments exist before casting added

#4 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #20265: jewel: [cli] ensure positional arguments exist before casting added

#5 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF