Project

General

Profile

Bug #20113

couldn't get command descriptions for [u'mgr', '']:

Added by Sage Weil 3 months ago. Updated 17 days ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
05/30/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

2017-05-30T19:19:08.840 INFO:tasks.workunit.client.0.smithi180.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:2095: test_mgr_tell_help_command:  ceph tell mgr help
2017-05-30T19:19:08.899 INFO:tasks.workunit.client.0.smithi180.stderr:2017-05-30 19:19:08.902375 7f8384dd1700 -1 WARNING: all dangerous and experimental features are enabled.
2017-05-30T19:19:08.908 INFO:tasks.workunit.client.0.smithi180.stderr:2017-05-30 19:19:08.911543 7f8384dd1700 -1 WARNING: all dangerous and experimental features are enabled.
2017-05-30T19:19:08.916 INFO:tasks.workunit.client.0.smithi180.stderr:couldn't get command descriptions for [u'mgr', '']:
2017-05-30T19:19:08.926 INFO:tasks.workunit.client.0.smithi180.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:1: test_mgr_tell_help_command:  rm -fr /tmp/cephtool.0SB
2017-05-30T19:19:08.928 INFO:tasks.workunit:Stopping ['cephtool'] on client.0...
2017-05-30T19:19:08.928 INFO:teuthology.orchestra.run.smithi180:Running: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0'
2017-05-30T19:19:09.025 ERROR:teuthology.run_tasks:Saw exception from tasks.

/a/sage-2017-05-30_17:22:40-rados-wip-sage-testing---basic-smithi/1244570
http://pulpito.ceph.com/sage-2017-05-30_17:22:40-rados-wip-sage-testing---basic-smithi/1244570

History

#1 Updated by Chang Liu 3 months ago

Sorry for this failed task. I'm working on it. Assignee it to me, please.

#2 Updated by Kefu Chai 3 months ago

Chang, you are not listed as a developer of this project. see http://tracker.ceph.com/projects/ceph. probably you ping any of the tech leaders (see "Manager" in the same webpage) to get you added?

#3 Updated by Kefu Chai 3 months ago

  • Status changed from New to In Progress

#4 Updated by Chang Liu 3 months ago

Kefu Chai wrote:

Chang, you are not listed as a developer of this project. see http://tracker.ceph.com/projects/ceph. probably you ping any of the tech leaders (see "Manager" in the same webpage) to get you added?

Thank you, Kefu, I will write a emall to get permission. : )

I have create a PR(https://github.com/ceph/ceph/pull/15378). Would you mind taking a look?

#5 Updated by Sage Weil 2 months ago

This is fixed, right? I haven't seen it in a couple weeks.

#6 Updated by Kefu Chai 2 months ago

i don't think it's fixed. we merged a PR by Chang to print more log on the "couldn't get command descriptions for [mgr...]" failure.

#7 Updated by Sage Weil 2 months ago

  • Status changed from In Progress to Need More Info
  • Priority changed from Immediate to Urgent

ok, downgrading and updating status. maybe this is secondary effect of having a flaky mgr (which is pretty stable now).

#8 Updated by Greg Farnum 2 months ago

  • Category set to 110

#9 Updated by Greg Farnum 2 months ago

  • Project changed from Ceph to mgr
  • Category deleted (110)

#10 Updated by Sage Weil about 2 months ago

  • Status changed from Need More Info to Can't reproduce

#11 Updated by Sage Weil 18 days ago

  • Status changed from Can't reproduce to Verified
  • Assignee set to Sage Weil

another instance:

2017-08-02T03:49:35.365 INFO:tasks.workunit.client.0.smithi100.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:2462: test_mgr_tell:  ceph tell mgr help
2017-08-02T03:49:35.450 INFO:tasks.workunit.client.0.smithi100.stderr:couldn't get command descriptions for [u'mgr']:  (-13)

and the mgr was online happy.

/a/sage-2017-08-02_01:58:49-rados-wip-sage-testing-distro-basic-smithi/1470020

#12 Updated by Sage Weil 18 days ago

I think that EACCES is coming from MgrClient.cc:

../src/mgr/MgrClient.cc:    ldout(cct,20) << " no MgrMap, assuming EACCES" << dendl;
../src/mgr/MgrClient.cc:    return -EACCES;

because we haven't gotten mgrmap from the mon. The maps are sent in alphanumeric order, which means that if we wait for osdmap, we'll have already gotten the mgrmap (and we'll avoid a potential problem with tell to an osd without an osdmap).

#13 Updated by Sage Weil 18 days ago

  • Status changed from Verified to Need Review

#14 Updated by Sage Weil 17 days ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF