Project

General

Profile

Bug #20100

get wrong content when download object with specific range when compression was enabled

Added by fang yuxiang 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/27/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
master
Needs Doc:
No

Description

create a bucket with compression enabled

Given a 32MB file, do steps:

1.divided the file into 4 parts
2.upload the file using swift slo
3.using curl -r to get the range [5348500, 5348700]
4.using readfile to read the source file range [5348500, 5348700]

the content from step 3 is different from step 4


Related issues

Copied to rgw - Backport #20268: kraken: get wrong content when download object with specific range when compression was enabled Resolved

History

#1 Updated by Nathan Cutler 5 months ago

  • Project changed from Ceph to rgw

#2 Updated by Casey Bodley 5 months ago

  • Status changed from New to Need Review

#3 Updated by fang yuxiang 5 months ago

the previous description is not proper.

In fact, this issue exists in s3 download with specific range for a multipart uploaded object.

For swift slo/dlo, the issue is more complicated and seems that compression can not be used at all(http://tracker.ceph.com/issues/20101)

#4 Updated by Radoslaw Zarzynski 4 months ago

  • Status changed from Need Review to Pending Backport
  • Backport set to kraken

#5 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #20268: kraken: get wrong content when download object with specific range when compression was enabled added

#6 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF