Project

General

Profile

Bug #19929

Lock release requests not honored after watch is re-acquired

Added by Jason Dillaman 4 months ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
05/15/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

After the watch fails, the lock owner client id is cleared and the re-acquire process is started. If the re-acquire is successful (supported by the OSDs), the lock owner client id will never be re-initialized. Since this is used as a guard for release lock request messages, the client in this state will just ACK the release request without actually starting the process.


Related issues

Copied to rbd - Backport #19957: jewel: rbd: Lock release requests not honored after watch is re-acquired Resolved

History

#1 Updated by Jason Dillaman 4 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Mykola Golub 4 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Alexey Sheplyakov 4 months ago

  • Copied to Backport #19957: jewel: rbd: Lock release requests not honored after watch is re-acquired added

#4 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #20005: kraken: Lock release requests not honored after watch is re-acquired added

#5 Updated by Jason Dillaman 22 days ago

  • Backport changed from kraken,jewel to jewel

#6 Updated by Nathan Cutler 15 days ago

  • Copied to deleted (Backport #20005: kraken: Lock release requests not honored after watch is re-acquired)

#7 Updated by Nathan Cutler 11 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF