Project

General

Profile

Bug #19832

Potential IO hang if image is flattened while read request is in-flight

Added by Jason Dillaman 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/03/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken,jewel,hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

If the child object doesn't exist and the parent is removed after the IO started, the IO will hang w/o completing.

https://github.com/ceph/ceph/blob/master/src/librbd/io/ObjectRequest.cc#L207

        if (image_ctx->parent == NULL) {
          ldout(image_ctx->cct, 20) << "parent is gone; do nothing" << dendl;
          m_state = LIBRBD_AIO_READ_FLAT;
          finished = false;
          break;
        }

The "finished = false" line should be removed


Related issues

Copied to rbd - Backport #20152: hammer: Potential IO hang if image is flattened while read request is in-flight Rejected
Copied to rbd - Backport #20153: jewel: Potential IO hang if image is flattened while read request is in-flight Resolved
Copied to rbd - Backport #20154: kraken: Potential IO hang if image is flattened while read request is in-flight Resolved

History

#1 Updated by Jason Dillaman 7 months ago

Looks like the issue was introduced in commit 190c185b74b5959000d8dc79e8ee0a10ed0fc979

#2 Updated by Mykola Golub 6 months ago

  • Status changed from New to Need Review

#3 Updated by Jason Dillaman 6 months ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #20152: hammer: Potential IO hang if image is flattened while read request is in-flight added

#5 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #20153: jewel: Potential IO hang if image is flattened while read request is in-flight added

#6 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #20154: kraken: Potential IO hang if image is flattened while read request is in-flight added

#7 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF