Project

General

Profile

Bug #19435

rgwfs hung due to missing unlock within unlink operation

Added by Hecheng Gui 8 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/31/2017
Due date:
% Done:

100%

Source:
Tags:
Backport:
jewel kraken
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

1. mkdir /mnt/dir1
2. touch /mnt/dir1/file1
3. rmdir /mnt/dir1
rmdir: failed to remove ‘/mnt/dir1’: Directory not empty
4. ls /mnt <-- hung

Due to a missing unlock before returning errcode from unlink


Related issues

Copied to rgw - Backport #19525: jewel: rgwfs hung due to missing unlock within unlink operation Resolved
Copied to rgw - Backport #19526: kraken: rgwfs hung due to missing unlock within unlink operation Resolved

History

#2 Updated by Matt Benjamin 8 months ago

  • Status changed from New to Pending Backport
  • Assignee set to Matt Benjamin
  • Backport set to jewel kraken
  • Severity changed from 3 - minor to 2 - major

#4 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #19525: jewel: rgwfs hung due to missing unlock within unlink operation added

#5 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #19526: kraken: rgwfs hung due to missing unlock within unlink operation added

#6 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF