Project

General

Profile

Bug #19205

Invalid error code returned by MDS is causing a kernel client WARNING

Added by Jan Fajerski 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/07/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
jewel
Component(FS):
Needs Doc:
No

Description

Found by an occasionally failing xfstest generic/011.

After some investigation, it was found out that a positive error code EISDIR was being received by the kernel client in fs/namei.c atomic_open().

Issue seems to be fixed by https://github.com/ceph/ceph/pull/9693. After including this commit 100 runs of said xfstest were successful


Related issues

Copied to fs - Backport #19206: jewel: Invalid error code returned by MDS is causing a kernel client WARNING Resolved

History

#1 Updated by Jan Fajerski 5 months ago

  • Copied to Backport #19206: jewel: Invalid error code returned by MDS is causing a kernel client WARNING added

#2 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF