Project

General

Profile

Bug #186

BUG: failed to decode message of type 66 v1: buffer::exception

Added by Wido den Hollander almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Monitor
Target version:
Start date:
06/08/2010
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

While my cluster was in a degraded state due to a disk failure at random 2 out of my 3 monitors crashed.

I really have no idea what was going on that particular moment since i was busy with replacing the failed drive.

My mon0 and mon2 crashed.

The backtrace and log was the same on mon0 and mon2. For the record i also added the log of mon1, which gives some information about the state of my cluster.

Both mon0 and mon2 crashed at the same time: 14:09

Haven't got any more information to go on

cmon_crash_at_random.txt View (1.36 KB) Wido den Hollander, 06/08/2010 06:41 AM

cmon_crash_log.txt View (2.11 KB) Wido den Hollander, 06/08/2010 06:41 AM

cmon_crash_mon1_log.txt View (49.8 KB) Wido den Hollander, 06/08/2010 06:41 AM

History

#1 Updated by Sage Weil almost 9 years ago

  • Status changed from New to In Progress
  • Assignee set to Sage Weil
  • Target version set to v0.21

This was due to 29a42efe2e4c789092f59b98b29632bdc4b88a80, which made a protocol change. I'll fix it up today to behave with a mix of old and new versions. In the meantime, just restart all your monitors with the new code and you should be fine.

#2 Updated by Sage Weil almost 9 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF