Project

General

Profile

Bug #18595

bluestore: allocator fails for 0x80000000 allocations

Added by Sage Weil 5 months ago. Updated 15 days ago.

Status:
Resolved
Priority:
Immediate
Assignee:
-
Category:
-
Target version:
-
Start date:
01/19/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No
Component(RADOS):
BlueStore

Description

I have a bluestore OSD that is near full where bluestore is calling BlueFS::reclaim_blocks. There is lots of space free, but the bitmap allocator is returning ENOSPC.

Log is attached.

ceph-osd.5.log.gz (227 KB) Sage Weil, 01/20/2017 01:11 AM

History

#1 Updated by Sage Weil 5 months ago

  • Subject changed from bitmap allocator: failure to allocate for bluefs reclaim to bluestore: allocator fails for 0x80000000 allocations

Turns out this is an int64_t -> int thing. bah!

#2 Updated by Sage Weil 5 months ago

  • Status changed from New to Resolved

#4 Updated by Greg Farnum 15 days ago

  • Project changed from Ceph to RADOS
  • Category deleted (107)

#5 Updated by Greg Farnum 15 days ago

  • Component(RADOS) BlueStore added

Also available in: Atom PDF