Project

General

Profile

Bug #18435

[ FAILED ] TestLibRBD.RenameViaLockOwner

Added by Jason Dillaman about 2 years ago. Updated 12 months ago.

Status:
Resolved
Priority:
Low
Target version:
-
Start date:
01/05/2017
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
luminous,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

http://qa-proxy.ceph.com/teuthology/trociny-2017-01-04_21:20:49-rbd-wip-mgolub-testing---basic-smithi/689831/teuthology.log

When injecting socket failures, if a socket failure results in multiple (duplicate) rename requests to the lock owner, the lock owner doesn't no-op the duplicate rename requests. This results in the rename request failing because it wasn't able to read the "rbd_id.<original image name>" object.


Related issues

Copied to rbd - Backport #22593: luminous: [ FAILED ] TestLibRBD.RenameViaLockOwner Resolved
Copied to rbd - Backport #22594: jewel: [ FAILED ] TestLibRBD.RenameViaLockOwner Resolved

History

#1 Updated by Jason Dillaman about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman over 1 year ago

  • Status changed from In Progress to New

#3 Updated by Jason Dillaman about 1 year ago

  • Status changed from New to In Progress
  • Backport set to luminous,jewel

#4 Updated by Jason Dillaman about 1 year ago

  • Status changed from In Progress to Need Review

#5 Updated by Mykola Golub about 1 year ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #22593: luminous: [ FAILED ] TestLibRBD.RenameViaLockOwner added

#7 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #22594: jewel: [ FAILED ] TestLibRBD.RenameViaLockOwner added

#8 Updated by Nathan Cutler 12 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF