Project

General

Profile

Bug #18429

Assertion failure if client is blacklisted with outstanding journaled IO

Added by Jason Dillaman 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
01/05/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

For example, run "rbd bench-write" against an image with journaling enabled and blacklist the client. The rbd CLI will crash with an assertion failure in regards to not being able to flush its journal event (since it's blacklisted).

History

#1 Updated by Jason Dillaman 11 months ago

  • Status changed from In Progress to Need Review

PR: included within https://github.com/ceph/ceph/pull/12639 (which will be backported to address the bug in previous releases)

#2 Updated by Mykola Golub 11 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF