Project

General

Profile

Bug #18388

qa/workunits/rbd/test_lock_fence.sh fails (regression)

Added by Nathan Cutler 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
01/02/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
hammer,jewel,kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

https://github.com/ceph/ceph/commit/cf294777ea92f0911813a7132068584d4f73a65a made the following change in qa/workunits/rbd/test_lock_fence.sh:

-RBDRW=rbdrw.py
-CEPH_REF=${CEPH_REF:-master}
-
-wget -O $RBDRW "https://git.ceph.com/?p=ceph.git;a=blob_plain;hb=$CEPH_REF;f=src/test/librbd/rbdrw.py" 
+RELPATH=$(dirname $0)/../../../src/test/pybind
+RBDRW=$RELPATH/rbdrw.py

This is wrong - RELPATH needs to be set to `$(dirname $0)/../../../src/test/librbd` - and causes failures like this:

http://qa-proxy.ceph.com/teuthology/smithfarm-2017-01-02_16:38:11-rbd-wip-hammer-backports-distro-basic-smithi/683330/teuthology.log (pertinent log excerpt follows)

2017-01-02T18:07:54.333 INFO:tasks.workunit:Running workunits matching rbd/test_lock_fence.sh on client.0...
2017-01-02T18:07:54.336 INFO:tasks.workunit:Running workunit rbd/test_lock_fence.sh...
2017-01-02T18:07:54.338 INFO:teuthology.orchestra.run.smithi057:Running (workunit test rbd/test_lock_fence.sh): 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && CEPH_CLI_TEST_DUP_COMMAND=1 CEPH_REF=b9c0f7248992ca37564263b6e9ee8d55c12c0a0f TESTDIR="/home/ubuntu/cephtest" CEPH_ID="0" PATH=$PATH:/usr/sbin CEPH_BASE=/home/ubuntu/cephtest/clone.client.0 adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 3h /home/ubuntu/cephtest/clone.client.0/qa/workunits/rbd/test_lock_fence.sh'
2017-01-02T18:07:54.352 INFO:tasks.workunit.client.0.smithi057.stderr:+ IMAGE=rbdrw-image
2017-01-02T18:07:54.355 INFO:tasks.workunit.client.0.smithi057.stderr:+ LOCKID=rbdrw
2017-01-02T18:07:54.358 INFO:tasks.workunit.client.0.smithi057.stderr:++ dirname /home/ubuntu/cephtest/clone.client.0/qa/workunits/rbd/test_lock_fence.sh
2017-01-02T18:07:54.360 INFO:tasks.workunit.client.0.smithi057.stderr:+ RELPATH=/home/ubuntu/cephtest/clone.client.0/qa/workunits/rbd/../../../src/test/pybind
2017-01-02T18:07:54.362 INFO:tasks.workunit.client.0.smithi057.stderr:+ RBDRW=/home/ubuntu/cephtest/clone.client.0/qa/workunits/rbd/../../../src/test/pybind/rbdrw.py
2017-01-02T18:07:54.364 INFO:tasks.workunit.client.0.smithi057.stderr:+ rbd create rbdrw-image --size 10 --image-format 2 --image-shared
2017-01-02T18:07:54.369 INFO:tasks.workunit.client.0.smithi057.stderr:2017-01-02 18:07:54.367816 7f3e1ab447c0  0 -- 172.21.15.57:0/867220220 submit_message mon_subscribe({monmap=2+,osdmap=0}) v2 remote, 172.21.15.57:6791/0, failed lossy con, dropping message 0x27e9820
2017-01-02T18:07:54.371 INFO:tasks.workunit.client.0.smithi057.stderr:2017-01-02 18:07:54.367846 7f3e0b7fe700  0 monclient: hunting for new mon
2017-01-02T18:07:55.931 INFO:tasks.workunit.client.0.smithi057.stderr:+ iochild=6315
2017-01-02T18:07:55.933 INFO:tasks.workunit.client.0.smithi057.stderr:+ LOCKS='{}'
2017-01-02T18:07:55.936 INFO:tasks.workunit.client.0.smithi057.stderr:+ python /home/ubuntu/cephtest/clone.client.0/qa/workunits/rbd/../../../src/test/pybind/rbdrw.py rbdrw-image rbdrw
2017-01-02T18:07:55.938 INFO:tasks.workunit.client.0.smithi057.stderr:+ '[' '{}' == '{}' ']'
2017-01-02T18:07:55.940 INFO:tasks.workunit.client.0.smithi057.stderr:++ rbd lock list rbdrw-image --format json
2017-01-02T18:07:55.942 INFO:tasks.workunit.client.0.smithi057.stderr:python: can't open file '/home/ubuntu/cephtest/clone.client.0/qa/workunits/rbd/../../../src/test/pybind/rbdrw.py': [Errno 2] No such file or directory

Same failure in kraken run: http://pulpito.ceph.com/teuthology-2017-01-02_11:00:03-rbd-kraken-distro-basic-smithi/682122/

This is a regression introduced by https://github.com/ceph/ceph/commit/cf294777ea92f0911813a7132068584d4f73a65a


Related issues

Copied to rbd - Backport #18390: hammer: qa/workunits/rbd/test_lock_fence.sh fails (regression) Resolved
Copied to rbd - Backport #18391: jewel: qa/workunits/rbd/test_lock_fence.sh fails (regression) Resolved
Copied to rbd - Backport #18392: kraken: qa/workunits/rbd/test_lock_fence.sh fails (regression) Resolved

History

#1 Updated by Nathan Cutler 11 months ago

  • Backport set to hammer,jewel,kraken

#2 Updated by Nathan Cutler 11 months ago

  • Description updated (diff)

#3 Updated by Nathan Cutler 11 months ago

  • Description updated (diff)
  • Priority changed from Normal to Urgent

Upping priority because it's a regression.

#4 Updated by Nathan Cutler 11 months ago

  • Status changed from In Progress to Need Review

#5 Updated by Nathan Cutler 11 months ago

  • Description updated (diff)

#6 Updated by Nathan Cutler 11 months ago

  • Description updated (diff)

As expected, found same failure in kraken run - added link to description.

#7 Updated by Nathan Cutler 11 months ago

  • Status changed from Need Review to Pending Backport

#8 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #18390: hammer: qa/workunits/rbd/test_lock_fence.sh fails (regression) added

#9 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #18391: jewel: qa/workunits/rbd/test_lock_fence.sh fails (regression) added

#10 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #18392: kraken: qa/workunits/rbd/test_lock_fence.sh fails (regression) added

#11 Updated by Nathan Cutler 11 months ago

  • Status changed from Pending Backport to Need Review

#12 Updated by Jason Dillaman 11 months ago

  • Status changed from Need Review to Pending Backport

#13 Updated by John Spray 11 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF