Project

General

Profile

Bug #18309

TestVolumeClient.test_evict_client failure creating pidfile

Added by John Spray 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Correctness/Safety
Target version:
-
Start date:
12/20/2016
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Component(FS):
ceph-fuse
Needs Doc:
No

Description

Consistent on master

http://pulpito.ceph.com/jspray-2016-12-19_21:05:25-fs-master-distro-basic-smithi/648157

I notice that the second client.guest mount is failing because of a PID file collision. I guess we either used to run these clients on separate servers, or maybe colliding PID files didn't used to be fatal in the client?


Related issues

Duplicated by fs - Bug #18362: Test failure: test_evict_client (tasks.cephfs.test_volume_client.TestVolumeClient) Duplicate 12/29/2016
Copied to fs - Backport #18439: kraken: TestVolumeClient.test_evict_client failure creating pidfile Resolved

History

#1 Updated by John Spray 6 months ago

  • Category set to Testing
  • Priority changed from Normal to Urgent
  • Component(FS) qa-suite added

#2 Updated by John Spray 6 months ago

  • Backport set to kraken

The problem is that global_init_prefork is calling pidfile_write, and we started using that from the client in 83aaa55d.

Probably just need to add a flag to those init functions for them to have a client-ish mode where we don't do pidfiles

#3 Updated by John Spray 6 months ago

  • Category changed from Testing to Correctness/Safety
  • Component(FS) ceph-fuse added
  • Component(FS) deleted (qa-suite)

#4 Updated by Nathan Cutler 6 months ago

  • Status changed from New to Need Review
  • Assignee set to Nathan Cutler

#5 Updated by Nathan Cutler 6 months ago

#6 Updated by Kefu Chai 6 months ago

  • Status changed from Need Review to Pending Backport

#7 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #18439: kraken: TestVolumeClient.test_evict_client failure creating pidfile added

#8 Updated by John Spray 5 months ago

  • Duplicated by Bug #18362: Test failure: test_evict_client (tasks.cephfs.test_volume_client.TestVolumeClient) added

#9 Updated by John Spray 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF