Project

General

Profile

Bug #18157

ceph-fuse segfaults on daemonize

Added by Greg Farnum 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
12/06/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Component(FS):
Needs Doc:
No

Description

gregf@rex004:~/ceph/build [master]$ ./bin/ceph-fuse mnt
2016-12-06 14:13:21.076022 7f6086337f00 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-12-06 14:13:21.076223 7f6086337f00 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-12-06 14:13:21.082155 7f6086337f00 -1 WARNING: the following dangerous and experimental features are enabled: *
2016-12-06 14:13:21.084666 7f6086337f00 -1 init, newargv = 0x7f6090b214a0 newargc=11
ceph-fuse[29732]: starting ceph client
ceph-fuse[29732]: starting fuse
Aborted (core dumped)
gregf@rex004:~/ceph/build [master]$
Core was generated by `./bin/ceph-fuse mnt'.
Program terminated with signal SIGABRT, Aborted.
#0  0x00007f608462a59b in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:37
37        return INLINE_SYSCALL (tgkill, 3, pid, THREAD_GETMEM (THREAD_SELF, tid),
Missing separate debuginfos, use: debuginfo-install fuse-libs-2.9.4-1.fc20.x86_64 gperftools-libs-2.1-4.fc20.x86_64 libunwind-1.1-3.fc20.x86_64 nspr-4.10.8-1.fc20.x86_64 nss-3.19.1-1.0.fc20.x86_64 nss-util-3.19.1-1.0.fc20.x86_64 zlib-1.2.8-3.fc20.x86_64
(gdb) bt
#0  0x00007f608462a59b in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:37
#1  0x00007f60865e0eb5 in reraise_fatal (signum=6) at /home/gregf/ceph/src/global/signal_handler.cc:72
#2  handle_fatal_signal (signum=6) at /home/gregf/ceph/src/global/signal_handler.cc:134
#3  <signal handler called>
#4  0x00007f6083447877 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#5  0x00007f6083448f68 in __GI_abort () at abort.c:89
#6  0x00007f608667c317 in ceph::__ceph_assert_fail (assertion=assertion@entry=0x7f6086910de1 "is_started()", file=file@entry=0x7f6086910fc8 "/home/gregf/ceph/src/log/Log.cc", line=line@entry=428, func=func@entry=0x7f60869110c0 <ceph::logging::Log::stop()::__PRETTY_FUNCTION__> "void ceph::logging::Log::stop()")
    at /home/gregf/ceph/src/common/assert.cc:78
#7  0x00007f6086680b64 in ceph::logging::Log::stop (this=0x7f6090b88000) at /home/gregf/ceph/src/log/Log.cc:428
#8  0x00007f6086786d06 in CephContext::~CephContext (this=0x7f6090b30000, __in_chrg=<optimized out>) at /home/gregf/ceph/src/common/ceph_context.cc:626
#9  0x00007f6086786fbc in CephContext::put (this=0x7f6090b30000) at /home/gregf/ceph/src/common/ceph_context.cc:647
#10 0x00007f6086528e45 in ~intrusive_ptr (this=0x7fffb9148620, __in_chrg=<optimized out>) at /home/gregf/ceph/build/boost/include/boost/smart_ptr/intrusive_ptr.hpp:97
#11 main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at /home/gregf/ceph/src/ceph_fuse.cc:82

History

#1 Updated by Greg Farnum 7 months ago

Not detected in nightlies because of #18158

#2 Updated by Greg Farnum 7 months ago

  • Status changed from New to Need Review

#3 Updated by Kefu Chai 7 months ago

#4 Updated by Greg Farnum 7 months ago

  • Priority changed from Immediate to Normal

We worked around this somewhat badly in master/kraken, but Kefu's Preforker change is a better option.

#5 Updated by Zheng Yan 6 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF