Project

General

Profile

Bug #18068

diff calculate can hide parent extents when examining first snapshot in clone

Added by Jason Dillaman about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
11/29/2016
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel,hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Create a clone from a parent image, create a snapshot on the clone, and write some data to the clone's HEAD revision. Attempting to export the clone's snapshot diff should return the parent history but instead excludes any parent extents where a backing object exists within the clone. Note: for >Infernalis, krbd is required to write to the clone since librbd will perform a CoW and the diff will include all parent extents.


Related issues

Copied to rbd - Backport #18110: jewel: diff calculate can hide parent extents when examining first snapshot in clone Resolved
Copied to rbd - Backport #18111: hammer: diff calculate can hide parent extents when examining first snapshot in clone Resolved

History

#1 Updated by Jason Dillaman about 1 year ago

  • Status changed from In Progress to Need Review

#2 Updated by Jason Dillaman about 1 year ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #18110: jewel: diff calculate can hide parent extents when examining first snapshot in clone added

#4 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #18111: hammer: diff calculate can hide parent extents when examining first snapshot in clone added

#5 Updated by Nathan Cutler about 1 year ago

Jason, I looked at the hammer backport but the whole file src/librbd/DiffIterate.cc appears to be missing in hammer.

#6 Updated by Nathan Cutler 10 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF