Project

General

Profile

Bug #18064

multisite: sync status reports master is on a different period

Added by Abhishek Lekshmanan 12 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
11/29/2016
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel, kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
jewel, kraken
Needs Doc:
No

Description

On current master, sync status on secondary reports that the master is on a different period, though the master and the secondary are actually in the same period, here dc1 is the primary and dc2 is the secondary zone

$ ./bin/radosgw-admin -c ./run/dc2/ceph.conf sync status
          realm a8a09e0f-f284-43ef-bbbd-7b9d09ff214d (gold)
      zonegroup 8b93e5ac-1997-4b99-b8cc-184c683993a7 (us)
           zone f42bfb1e-aa15-4429-ae13-cbc5d1c4267c (us-west)
  metadata sync syncing
                full sync: 0/64 shards
                master is on a different period: master_period=3e6d994f-e3e8-4191-9780-6423a393e903 local_period=a2012652-9795-4550-8c0b-62b13a9a5331
                metadata is caught up with master
                incremental sync: 64/64 shards
      data sync source: 83337a5d-15c3-4e11-8bda-82d9bed80694 (us-east-1)
                        syncing
                        full sync: 0/128 shards
                        incremental sync: 128/128 shards
                        data is caught up with source

$ ./bin/radosgw-admin -c ./run/dc1/ceph.conf period get-current
{
    "current_period": "a2012652-9795-4550-8c0b-62b13a9a5331" 
}

$ ./bin/radosgw-admin -c ./run/dc2/ceph.conf period get-current                                                          
{
    "current_period": "a2012652-9795-4550-8c0b-62b13a9a5331" 
}


Related issues

Copied to rgw - Backport #18684: jewel: multisite: sync status reports master is on a different period Resolved
Copied to rgw - Backport #18709: kraken: multisite: sync status reports master is on a different period Resolved

History

#1 Updated by Abhishek Lekshmanan 12 months ago

Looking further into this I see that we're actually storing master_period as the first period from master instead of master's current period, since this is populated from /admin/log metadata which actually returns the first period of master. We could get master's current period and compare that instead

#2 Updated by Abhishek Lekshmanan 12 months ago

  • Status changed from New to In Progress
  • Assignee set to Abhishek Lekshmanan

#4 Updated by Abhishek Lekshmanan 10 months ago

  • Status changed from In Progress to Need Review

#5 Updated by Abhishek Lekshmanan 10 months ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Abhishek Lekshmanan 10 months ago

  • Backport set to jewel
  • Release jewel added

#7 Updated by Loic Dachary 10 months ago

  • Copied to Backport #18684: jewel: multisite: sync status reports master is on a different period added

#8 Updated by Abhishek Lekshmanan 10 months ago

  • Backport changed from jewel to jewel, kraken
  • Release kraken added

#9 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #18709: kraken: multisite: sync status reports master is on a different period added

#10 Updated by Nathan Cutler 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF