Project

General

Profile

Bug #17899

restarting an osd twice quickly enough with no other map changes can leave it running, but not up

Added by Samuel Just about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
11/14/2016
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Restarting an osd twice quickly enough can result in it starting up and sending an MOSDBoot message with the same epoch as the epoch in which it was marked up_from. The mon then ignores the boot message and leaves the osd in limbo since it won't resend the boot.


Related issues

Copied to Ceph - Backport #17953: jewel: restarting an osd twice quickly enough with no other map changes can leave it running, but not up Resolved

History

#1 Updated by Samuel Just about 1 year ago

  • Status changed from New to Pending Backport
  • Backport set to jewel

Merge: 83ce0fe2f4f6e17a761586606813f02d1c86ebee

#2 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #17953: jewel: restarting an osd twice quickly enough with no other map changes can leave it running, but not up added

#3 Updated by Nathan Cutler 11 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF