Project

General

Profile

Bug #17100

tests: scsi_debug fails /dev/disk/by-partuuid

Added by Loic Dachary almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
08/23/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

When using modprobe scsi_debug in qa/workunits/ceph-disk/ceph-disk-test.py to provide a SCSI device and test multipath, it does not get the /dev/disk/by-partuuid aliasing because it does not pass the filters of the default /lib/udev/rules.d/60-persistent-storage.rules

It was not a problem back when the 60-ceph-partuuid-workaround-rules file was around because it (redundantly) created the /dev/disk/by-partuuid anyway. Since 9f76b9ff31525eac01f04450d72559ec99927496 removed this file, it no longer happens and the test fail. This does not appear to be a problem in the real world, only for tests.


Related issues

Related to Ceph - Bug #17078: bluestore: ceph-disk-test.py fails with fsck leaked some space Resolved 08/19/2016
Copied to Ceph - Backport #17245: jewel: tests: scsi_debug fails /dev/disk/by-partuuid Resolved

History

#1 Updated by Loic Dachary almost 3 years ago

  • Status changed from In Progress to Need Review
  • Assignee set to Loic Dachary

#2 Updated by Loic Dachary almost 3 years ago

  • Related to Bug #17078: bluestore: ceph-disk-test.py fails with fsck leaked some space added

#3 Updated by Kefu Chai almost 3 years ago

  • Status changed from Need Review to Resolved

#4 Updated by Loic Dachary almost 3 years ago

  • Status changed from Resolved to Pending Backport

#5 Updated by Loic Dachary almost 3 years ago

  • Copied to Backport #17245: jewel: tests: scsi_debug fails /dev/disk/by-partuuid added

#6 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF