Project

General

Profile

Bug #16949

rpm: ceph installs stuff in %_udevrulesdir but does not own that directory

Added by Nathan Cutler 10 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
08/07/2016
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:

Description

The ceph.spec.in file makes sure %_udevrulesdir is defined, and then it installs stuff in it, but it's missing a %dir %_udevrulesdir directive.

Also, %_udevrulesdir is expected to resolve to either /lib/udev/rules.d or /usr/lib/udev/rules.d - so %dir %_udevrulesdir is not sufficient. We also need a %dir /usr/lib/udev but that's not so easy. . .

In SUSE, until recently we were relying on hdparm to provide these directories. Since the "udev" package in SUSE provides the directories, adding "BuildRequires: udev" should be sufficient there.


Related issues

Copied to Backport #17095: jewel: rpm: ceph installs stuff in %_udevrulesdir but does not own that directory Resolved

History

#1 Updated by Nathan Cutler 10 months ago

  • Status changed from New to Need Review

#2 Updated by Nathan Cutler 10 months ago

  • Priority changed from Normal to Urgent

#3 Updated by Nathan Cutler 9 months ago

  • Status changed from Need Review to Pending Backport
  • Priority changed from Urgent to High

#4 Updated by Nathan Cutler 9 months ago

  • Copied to Backport #17095: jewel: rpm: ceph installs stuff in %_udevrulesdir but does not own that directory added

#5 Updated by Loic Dachary 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF