Project

General

Profile

Bug #16673

rgw: setting rgw_swift_url_prefix = "/" doesn't work as expected

Added by Radoslaw Zarzynski 10 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
07/13/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

According to the RadosGW's documentation in Jewel:

 ``rgw swift url prefix``

 :Description: The URL prefix for the Swift StorageURL that goes in front of
               the "/v1" part. This allows to run several Gateway instances
               on the same host. For compatibility, setting this configuration
               variable to empty causes the default "/swift" to be used.
               Use explicit prefix "/" to start StorageURL at the root.

Unfortunately, the special "/" case doesn't work. For details please take a look on the comment in PR #9582.


Related issues

Copied to Backport #17208: jewel: rgw: setting rgw_swift_url_prefix = "/" doesn't work as expected Resolved

History

#1 Updated by Radoslaw Zarzynski 10 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Radoslaw Zarzynski 8 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Yehuda Sadeh 8 months ago

  • Status changed from Pending Backport to Resolved

Since backport is non trivial, closing it. We can reopen again if needed.

#4 Updated by Yehuda Sadeh 8 months ago

  • Status changed from Resolved to Pending Backport

close wrong bug

#5 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #17208: jewel: rgw: setting rgw_swift_url_prefix = "/" doesn't work as expected added

#6 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF