Project

General

Profile

Bug #16329

rbd-mirror: gracefully handle missing sync point snapshots

Added by Jason Dillaman almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
06/15/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

If the sync point snapshot for an image being bootstrapped is deleted and the bootstrap is restarted, the bootstrap state machine will see the existing sync point record and associated snapshot name, but it doesn't validate that the snapshot actually exists. If the snapshot doesn't exist, it can lead to an assertion failure since there should always be at least one snapshot to sync from remote to local image.


Related issues

Copied to rbd - Backport #16373: jewel: rbd-mirror: gracefully handle missing sync point snapshots Resolved

History

#1 Updated by Jason Dillaman almost 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman almost 3 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Jason Dillaman almost 3 years ago

  • Subject changed from rbd-mirror: gracefully handling missing sync point snapshots to rbd-mirror: gracefully handle missing sync point snapshots

#4 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Need Review to Pending Backport
  • Backport set to jewel

#5 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #16373: jewel: rbd-mirror: gracefully handle missing sync point snapshots added

#6 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF