Project

General

Profile

Bug #15764

rbd-mirror bootstrap fails with -EEXIST when creating local image

Added by Jason Dillaman over 2 years ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/06/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The rbd-mirror daemon had previously crashed so it's possible that it raced creating the image and registering it with the mirroring directory:

2016-05-05 21:01:18.089290 7f2abdff3700 20 rbd::mirror::image_replayer::BootstrapRequest: 0x7f2aa000aec0 get_local_image_id
2016-05-05 21:01:18.089990 7f2adcff9700 20 rbd::mirror::image_replayer::BootstrapRequest: 0x7f2aa000aec0 handle_get_local_image_id: r=-2
2016-05-05 21:01:18.089995 7f2adcff9700 10 rbd::mirror::image_replayer::BootstrapRequest: 0x7f2aa000aec0 handle_get_local_image_id: image not registered locally
2016-05-05 21:01:18.142899 7f2ae5bc7700 20 rbd::mirror::image_replayer::BootstrapRequest: 0x7f2aa000aec0 handle_create_local_image: r=-17
2016-05-05 21:01:18.142903 7f2ae5bc7700 -1 rbd::mirror::image_replayer::BootstrapRequest: 0x7f2aa000aec0 handle_create_local_image: failed to create local image: (17) File exists

History

#1 Updated by Jason Dillaman over 2 years ago

  • Backport set to jewel

#2 Updated by Venky Shankar over 2 years ago

  • Assignee set to Venky Shankar

#3 Updated by Venky Shankar about 2 years ago

  • Status changed from New to Need Review

#4 Updated by Jason Dillaman over 1 year ago

  • Backport deleted (jewel)

#5 Updated by Jason Dillaman about 1 year ago

  • Status changed from Need Review to Resolved

#6 Updated by liuzhong chen 10 months ago

This issue looks serious.It means if the rbd-mirror daemon had previously crashed,I can't bootstrap it again?
And I find this patch was signed backport to Jewel but not do this,is there any problem or something else? Thank you!

#7 Updated by Jason Dillaman 10 months ago

@liuzhong chen: why are you commenting on old, resolved issues?

#8 Updated by liuzhong chen 10 months ago

@Jason Dillaman because I have to use rbd mirror of Jewel.I look for all bugfix after Jewel about rbd mirror.I find some issue that may affect use was signed backport to Jewel but not do.So I try to understand how much impact on Jewel of these issues or if there are some problem to backport to Jewel.

Also available in: Atom PDF