Project

General

Profile

Bug #15761

When journaling is enabled, a flush request shouldn't flush the cache

Added by Jason Dillaman almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/06/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

librbd currently flushes the journal and flushes the cache. It is not necessary to flush the cache since upon a crash the journal will be replayed. This would improve the latency of flush requests.


Related issues

Copied to rbd - Backport #16315: jewel: When journaling is enabled, a flush request shouldn't flush the cache Resolved

History

#1 Updated by Jason Dillaman almost 3 years ago

  • Backport set to jewel

#3 Updated by Jason Dillaman almost 3 years ago

  • Status changed from New to Need Review

#4 Updated by Jason Dillaman almost 3 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #16315: jewel: When journaling is enabled, a flush request shouldn't flush the cache added

#6 Updated by Loic Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF