Project

General

Profile

Bug #15618

'period update' does not remove short_zone_ids of deleted zones

Added by Casey Bodley about 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
04/26/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

After 'zone delete' and 'period update', the deleted zone's id is still listed under the period's short_zone_ids.

http://pastebin.test.redhat.com/369039


Related issues

Copied to rgw - Backport #19341: jewel: 'period update' does not remove short_zone_ids of deleted zones Resolved
Copied to rgw - Backport #19342: kraken: 'period update' does not remove short_zone_ids of deleted zones Resolved

History

#1 Updated by Abhishek Lekshmanan about 1 year ago

Don't we still reference the short zone ids for determining source of an object etc. will there be any effect if we end up totally removing it on zone deletion?

#2 Updated by Casey Bodley about 1 year ago

As far as I can tell, there aren't any code paths that look up other zones from the period's short_zone_ids map. The only user of this map is on startup, for the current gateway to learn its own short id for RGWRados::get_zone_short_id().

#3 Updated by Yehuda Sadeh about 1 year ago

the short zone id is stored on the objects, and serves as a tie breaker for sync

#4 Updated by Casey Bodley about 1 year ago

  • Status changed from New to Closed

it turns out that we do want to keep deleted zones in the period, so we can check new zones against them for hash collisions

#5 Updated by Casey Bodley 5 months ago

  • Status changed from Closed to In Progress

reopened after further discussion

#6 Updated by Casey Bodley 5 months ago

  • Status changed from In Progress to Need Review

#7 Updated by Casey Bodley 4 months ago

  • Status changed from Need Review to Pending Backport
  • Backport set to jewel kraken

#8 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19341: jewel: 'period update' does not remove short_zone_ids of deleted zones added

#9 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19342: kraken: 'period update' does not remove short_zone_ids of deleted zones added

#10 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF